Tag Archives: readynas

Netgear ReadyNAS Duo And Windows 7 Don’t Mix!


Update 04/01/2012: After many many months of trying to get this to work I ended up selling it on eBay. Worked fine for me using any Linux distribution but using Windows 7…forget it. Always had all sorts of trouble. I run a windows server box at home now and no issues.

Ok, so last November I went out and got myself a Netgear ReadyNAS Duo network attached storage (NAS) device. All in all its pretty nice, has very low power consumption and good performance…but when trying to browse the NAS using Windows 7 I’ve had all sorts of issues.

Now, Windows 7 introduced some new features to help improve network access by caching and perfetching network data differently to how it was done in Windows XP. Windows 7 may also have some improvements made to SAMBA and CIFS protocols that maybe the readynas doesn’t support? I’m not really sure but read/write performance using windows 7 to the readyNAS is really not that good, but the problem is random. Sometimes it’s problematic and others its fine.

It’s really strange. I’ve used different linux distributions which all play just fine with it, my iPad has no problems with it and our XBOX 360’s in the house can all stream music, photos and video from it no problem. It’s really just Windows 7 that doesn’t like it.

A small rant for today, maybe others out there have had similar problems with the ReadyNAS and Windows 7? If you have pls post a comment below and share your experiences and maybe even a solution to the problem. I’ve tried turning off the newer prefetching, etc in Windows 7 with no luck. Tried reducing the MTU of my Win7 box and the NAS below 1500 but still no luck.

Ah well, i’ll figure it out eventually.